May
29
2014
By Titto Jose

The Drupal 6 & 7 is shipped with jQuery library which is older than the current version that is available. Drupal 6 has version 1.2.6 and drupal 7 has 1.4.4. This offcourse can be updated to newer version using jQuery update module (Drupal 6 to jQuery 1.3.2 & Drupal 7 to jQuery 1.5.1, 1.7.1, or 1.8.2). For Drupal 7 I have seen that it causes certain minor issues (especially in Views UI) when it is set to 1.8. So the safest you can update to is 1.7 (correct me if I am wrong).

...